April, 2026
Incident Updates
Monday, April 20th
No Incidents
Tuesday, April 21st
No Incidents
Wednesday, April 22nd
RESOLVED
Internet Outage - Affects all Sites
DOWN
Crestfield Manor
DOWN
Walker Butte K-8
DOWN
Copper Basin K-8
DOWN
Desert Rock Church
DOWN
Gilbert & Warner Tower
DOWN
Anthem K-8 Tower
Updates
- RESOLVED
We identified the issue. It has been resolved.
We are investigating the root cause of the issue currently.
- INVESTIGATING
We are investingating the source of the outage currently.
Thursday, April 23rd
No Incidents
Friday, April 24th
No Incidents